summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rwxr-xr-xflake.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 7d5fba5..2a04e87 100755
--- a/flake.nix
+++ b/flake.nix
@@ -119,6 +119,34 @@
         };
       };
 
+      Rory-portable = nixpkgs.lib.nixosSystem {
+        system = "x86_64-linux";
+        modules = [
+          ./host/Rory-portable/configuration.nix
+          ./hardware-configuration.nix
+          home-manager.nixosModules.home-manager
+          ({...}: { 
+            nix = {
+              registry.nixpkgs.flake = nixpkgs;
+              nixPath = [
+                "nixpkgs=${nixpkgs.outPath}"
+              ];
+            };
+          })
+          # ... add this line to the rest of your configuration modules
+          #nix-ld.nixosModules.nix-ld
+
+          # The module in this repository defines a new module under (programs.nix-ld.dev) instead of (programs.nix-ld) 
+          # to not collide with the nixpkgs version.
+          #{ programs.nix-ld.dev.enable = true; }
+        ];
+        specialArgs = {
+          inherit home-manager;
+          inherit (inputs) mtxclientSrc;
+          inherit (inputs) nhekoSrc;
+        };
+      };
+
       #STABLE
       RoryNix = nixpkgs-RoryNix.lib.nixosSystem {
         system = "i686-linux";