summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorRory& <root@rory.gay>2024-06-10 17:33:26 +0200
committerRory& <root@rory.gay>2024-07-04 14:45:02 +0200
commite37b430512bbef89dfe8ab75454286de4836ab6e (patch)
treeaf3468855573725fefc29ab8935edcc663d6b6a3 /flake.nix
parentBunch of changes (diff)
downloadRory-Open-Architecture-e37b430512bbef89dfe8ab75454286de4836ab6e.tar.xz
Add portable config, some updates
Diffstat (limited to 'flake.nix')
-rwxr-xr-xflake.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 7d5fba5..2a04e87 100755
--- a/flake.nix
+++ b/flake.nix
@@ -119,6 +119,34 @@
         };
       };
 
+      Rory-portable = nixpkgs.lib.nixosSystem {
+        system = "x86_64-linux";
+        modules = [
+          ./host/Rory-portable/configuration.nix
+          ./hardware-configuration.nix
+          home-manager.nixosModules.home-manager
+          ({...}: { 
+            nix = {
+              registry.nixpkgs.flake = nixpkgs;
+              nixPath = [
+                "nixpkgs=${nixpkgs.outPath}"
+              ];
+            };
+          })
+          # ... add this line to the rest of your configuration modules
+          #nix-ld.nixosModules.nix-ld
+
+          # The module in this repository defines a new module under (programs.nix-ld.dev) instead of (programs.nix-ld) 
+          # to not collide with the nixpkgs version.
+          #{ programs.nix-ld.dev.enable = true; }
+        ];
+        specialArgs = {
+          inherit home-manager;
+          inherit (inputs) mtxclientSrc;
+          inherit (inputs) nhekoSrc;
+        };
+      };
+
       #STABLE
       RoryNix = nixpkgs-RoryNix.lib.nixosSystem {
         system = "i686-linux";