summary refs log tree commit diff
path: root/synapse/metrics/metric.py (follow)
Commit message (Expand)AuthorAgeFilesLines
* remove old metrics libsAmber Brown2018-05-211-328/+0
* Note that label values can be anythingErik Johnston2018-05-031-1/+2
* Fix metrics that have integer value labelsErik Johnston2018-05-031-1/+1
* Make _escape_character take MatchObjectErik Johnston2018-05-021-2/+10
* Escape label values in prometheus metricsErik Johnston2018-05-021-2/+20
* s/list/tupleErik Johnston2018-04-121-2/+2
* Add GaugeMetricErik Johnston2018-04-111-0/+30
* report metrics on number of cache evictionsRichard van der Hoff2018-02-051-1/+10
* better exception logging in callbackmetricsRichard van der Hoff2018-01-181-1/+8
* mechanism to render metrics with alternative namesRichard van der Hoff2018-01-151-13/+40
* Add some comments to metrics classesRichard van der Hoff2018-01-151-1/+27
* Make Counter render floatsRichard van der Hoff2018-01-121-3/+10
* Callback metric values might not just be integers - allow floatsPaul "LeoNerd" Evans2016-10-191-2/+2
* Make psutil optionalErik Johnston2016-08-081-3/+2
* Don't explode if we have no snapshots yetErik Johnston2016-07-201-0/+3
* Add metrics for psutil derived memory usageErik Johnston2016-07-201-0/+38
* Change CacheMetrics to be quickerErik Johnston2016-06-031-22/+22
* copyrightsMatthew Hodgson2016-01-071-1/+1
* Appease pep8Paul "LeoNerd" Evans2015-03-121-5/+6
* Add an .inc_by() method to CounterMetric; implement DistributionMetric a neat...Paul "LeoNerd" Evans2015-03-121-23/+14
* Rename TimerMetric to DistributionMetric; as it could count more than just timePaul "LeoNerd" Evans2015-03-121-11/+13
* Export CacheMetric as hits+total, rather than hits+misses, as it's easier to ...Paul "LeoNerd" Evans2015-03-121-5/+6
* Prometheus needs "escaped" label valuesPaul "LeoNerd" Evans2015-03-121-2/+6
* Kill unused CounterMetric.fetch() methodPaul "LeoNerd" Evans2015-03-121-3/+0
* Bugfix to rendering output of vectored TimerMetricsPaul "LeoNerd" Evans2015-03-121-3/+2
* Rename Metrics' "keys" to "labels"Paul "LeoNerd" Evans2015-03-121-12/+12
* Neater implementation of metric render methods by pulling out 'render' as a b...Paul "LeoNerd" Evans2015-03-121-18/+15
* Initial hack at a TimerMetric; for storing counts + duration accumulatorsPaul "LeoNerd" Evans2015-03-121-0/+48
* Implement vector CallbackMetricsPaul "LeoNerd" Evans2015-03-121-2/+6
* Neater introspection methods on BaseMetric so that subclasses don't need to t...Paul "LeoNerd" Evans2015-03-121-4/+11
* Rename CacheCounterMetric to just CacheMetric; add a CallbackMetric component...Paul "LeoNerd" Evans2015-03-121-4/+9
* Initial attempt at a scalar callback-based metric to give instantaneous snaps...Paul "LeoNerd" Evans2015-03-121-0/+14
* Create the concept of a cachecounter metric; generating two counters specific...Paul "LeoNerd" Evans2015-03-121-6/+37
* Initial tiny attempt at (vectorable) counter metricsPaul "LeoNerd" Evans2015-03-121-0/+54