summary refs log tree commit diff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNicolas Werner <nicolas.werner@hotmail.de>2020-06-24 14:48:02 +0200
committerNicolas Werner <nicolas.werner@hotmail.de>2020-06-26 13:36:21 +0200
commitda975038db397cc7f6a7d72b50d54e0a57549463 (patch)
tree53a7d7dc1d8d9e3f453b78a68dc47853dcd4a12b /CMakeLists.txt
parentDon't use formatted body without format (diff)
downloadnheko-da975038db397cc7f6a7d72b50d54e0a57549463.tar.xz
Drop libsodium dependency
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 04baf360..84438045 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,8 +35,6 @@ option(USE_BUNDLED_JSON "Use the bundled version of nlohmann json."
 option(USE_BUNDLED_OPENSSL "Use the bundled version of OpenSSL."
 	${HUNTER_ENABLED})
 option(USE_BUNDLED_MTXCLIENT "Use the bundled version of the Matrix Client library." ${HUNTER_ENABLED})
-option(USE_BUNDLED_SODIUM "Use the bundled version of libsodium."
-	${HUNTER_ENABLED})
 option(USE_BUNDLED_LMDB "Use the bundled version of lmdb."
 	${HUNTER_ENABLED})
 option(USE_BUNDLED_LMDBXX "Use the bundled version of lmdb++."
@@ -337,7 +335,7 @@ if(USE_BUNDLED_MTXCLIENT)
 	FetchContent_Declare(
 		MatrixClient
 		GIT_REPOSITORY https://github.com/Nheko-Reborn/mtxclient.git
-		GIT_TAG        v0.3.1
+		GIT_TAG        68e043e1bf515e9072235151f74f7aac0838a9d3
 		)
 	FetchContent_MakeAvailable(MatrixClient)
 else()