summary refs log tree commit diff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoseph Donofry <joedonofry@gmail.com>2019-06-11 21:04:30 -0400
committerJoseph Donofry <joedonofry@gmail.com>2019-06-11 21:04:30 -0400
commit9159b9ce22efa4972792b5400fd384457c349caa (patch)
tree2ef9f12d1011ea6a163e177ed7b639b9cbad1bb9 /CMakeLists.txt
parentAdd initial support for rich replies to nheko (diff)
downloadnheko-9159b9ce22efa4972792b5400fd384457c349caa.tar.xz
Initial Support for Rich Replies
Add placeholder UI for showing replies in the text entry widget.
Existing quoting capability has been removed (Temporarily), as
it was replaced with the new reply capability.  Replies sent from
nheko do not currently appear correctly in the timeline (this
will be fixed in a future commit).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fda60b71..321234dd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -237,7 +237,9 @@ set(SRC_FILES
     src/RunGuard.cpp
     src/SideBarActions.cpp
     src/Splitter.cpp
-    src/SuggestionsPopup.cpp
+    src/popups/SuggestionsPopup.cpp
+    src/popups/PopupItem.cpp
+    src/popups/ReplyPopup.cpp
     src/TextInputWidget.cpp
     src/TopRoomBar.cpp
     src/TrayIcon.cpp
@@ -375,7 +377,9 @@ qt5_wrap_cpp(MOC_HEADERS
     src/RoomList.h
     src/SideBarActions.h
     src/Splitter.h
-    src/SuggestionsPopup.h
+    src/popups/SuggestionsPopup.h
+    src/popups/ReplyPopup.h
+    src/popups/PopupItem.h
     src/TextInputWidget.h
     src/TopRoomBar.h
     src/TrayIcon.h