summary refs log tree commit diff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKonstantinos Sideris <sideris.konstantin@gmail.com>2017-07-29 11:49:00 +0300
committerKonstantinos Sideris <sideris.konstantin@gmail.com>2017-07-30 14:30:55 +0300
commit8d05073547d02e105712713de39e8359980812c2 (patch)
tree4a806e19b70f4b95f242752b7d7f601c05376026 /CMakeLists.txt
parentAdd serialization on matrix events (diff)
downloadnheko-8d05073547d02e105712713de39e8359980812c2.tar.xz
Initial support for state cache
- Adds detection for duplicate events
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3b352730..12acb35a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,6 +5,15 @@ project(nheko CXX)
 option(BUILD_TESTS "Build all tests" OFF)
 
 #
+# LMDB
+#
+find_path (LMDB_INCLUDE_DIR NAMES lmdb.h PATHS "$ENV{LMDB_DIR}/include")
+find_library (LMDB_LIBRARY NAMES lmdb PATHS "$ENV{LMDB_DIR}/lib" )
+
+include(FindPackageHandleStandardArgs)
+find_package_handle_standard_args(LMDB DEFAULT_MSG LMDB_INCLUDE_DIR LMDB_LIBRARY)
+
+#
 # Discover Qt dependencies.
 #
 find_package(Qt5Widgets REQUIRED)
@@ -93,6 +102,7 @@ endif()
 set(SRC_FILES
     src/AvatarProvider.cc
     src/ChatPage.cc
+    src/Cache.cc
     src/Deserializable.cc
     src/EmojiCategory.cc
     src/EmojiItemDelegate.cc
@@ -172,6 +182,7 @@ include_directories(include)
 include_directories(include/ui)
 include_directories(include/events)
 include_directories(include/events/messages)
+include_directories(libs/lmdbxx)
 
 qt5_wrap_cpp(MOC_HEADERS
     include/AvatarProvider.h
@@ -273,7 +284,7 @@ else()
     #
     # Build the executable.
     #
-    SET (NHEKO_LIBS matrix_events Qt5::Widgets Qt5::Network)
+    set (NHEKO_LIBS matrix_events Qt5::Widgets Qt5::Network ${LMDB_LIBRARY})
     set (NHEKO_DEPS ${OS_BUNDLE} ${SRC_FILES} ${UI_HEADERS} ${MOC_HEADERS} ${QRC} ${LANG_QRC} ${QM_SRC})
 
     if(APPLE)