summary refs log tree commit diff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMax Sandholm <max@sandholm.org>2018-07-11 17:33:02 +0300
committermujx <mujx@users.noreply.github.com>2018-07-11 17:33:02 +0300
commit80ebe3f29debb7f2020757252d1e2b4ae8a45869 (patch)
tree07a9bb42e559503787fbde1fd4eec7922bbafed0 /CMakeLists.txt
parentUse QSharedPointer::data to be compatible with Qt < 5.11 (diff)
downloadnheko-80ebe3f29debb7f2020757252d1e2b4ae8a45869.tar.xz
Working D-Bus desktop notifications (#361)
* Working D-Bus desktop notifications

* Remove return type on constructor

* Fix the Windows placeholder class

* Fix wrong variable name

* Fix windows and macOS versions of notificationsmanager
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7aa75a3e..48d739d0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -67,6 +67,7 @@ include(LMDB)
 # Discover Qt dependencies.
 #
 find_package(Qt5 COMPONENTS Core Widgets LinguistTools Concurrent Svg Multimedia REQUIRED)
+find_package(Qt5DBus)
 
 if (APPLE)
     find_package(Qt5MacExtras REQUIRED)
@@ -304,6 +305,8 @@ qt5_wrap_cpp(MOC_HEADERS
     include/ui/Theme.h
     include/ui/ThemeManager.h
 
+    include/notifications/Manager.h
+
     include/AvatarProvider.h
     include/Cache.h
     include/ChatPage.h
@@ -386,7 +389,7 @@ elseif(WIN32)
     target_link_libraries (nheko ${NTDLIB} ${NHEKO_LIBS} Qt5::WinMain)
 else()
     add_executable (nheko ${OS_BUNDLE} ${NHEKO_DEPS})
-    target_link_libraries (nheko ${NHEKO_LIBS})
+    target_link_libraries (nheko ${NHEKO_LIBS} Qt5::DBus)
 endif()
 
 if(EXTERNAL_PROJECT_DEPS)