summary refs log tree commit diff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorredsky17 <joedonofry@gmail.com>2019-02-24 19:50:31 +0000
committerredsky17 <joedonofry@gmail.com>2019-02-24 20:05:11 +0000
commit75fb95855d9f48f531c62028c30d3b588a23710a (patch)
treeefa3aca1f0e3cadd3ff34320fc1c2a35f56de3e9 /CMakeLists.txt
parentMerge pull request #32 from Vistaus/master (diff)
downloadnheko-75fb95855d9f48f531c62028c30d3b588a23710a.tar.xz
Nlohmann build updates
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ca343881..352542a1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -251,6 +251,8 @@ set(SRC_FILES
 # ExternalProject dependencies
 set(EXTERNAL_PROJECT_DEPS "")
 
+include(FeatureSummary)
+
 set(Boost_USE_STATIC_LIBS OFF)
 set(Boost_USE_STATIC_RUNTIME OFF)
 set(Boost_USE_MULTITHREADED ON)
@@ -269,6 +271,12 @@ find_package(MatrixClient 0.1.0 REQUIRED)
 find_package(Olm 2 REQUIRED)
 find_package(spdlog 1.0.0 CONFIG REQUIRED)
 find_package(cmark REQUIRED)
+find_package(nlohmann_json 3.2.0)
+set_package_properties(nlohmann_json PROPERTIES
+    DESCRIPTION "JSON for Modern C++, a C++11 header-only JSON class"
+    URL "https://nlohmann.github.io/json/"
+    TYPE REQUIRED
+)
 
 if(NOT LMDBXX_INCLUDE_DIR)
     find_path(LMDBXX_INCLUDE_DIR
@@ -296,6 +304,8 @@ include_directories(${Boost_INCLUDE_DIRS})
 # local inclue directory
 include_directories(includes)
 
+feature_summary(WHAT ALL INCLUDE_QUIET_PACKAGES FATAL_ON_MISSING_REQUIRED_PACKAGES)
+
 qt5_wrap_cpp(MOC_HEADERS
     # Dialogs
     src/dialogs/CreateRoom.h
@@ -387,7 +397,8 @@ set(COMMON_LIBS
     Qt5::Widgets
     Qt5::Svg
     Qt5::Concurrent
-    Qt5::Multimedia)
+    Qt5::Multimedia
+    nlohmann_json::nlohmann_json)
 
 if(APPVEYOR_BUILD)
     set(NHEKO_LIBS ${COMMON_LIBS} lmdb)