summary refs log tree commit diff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorredsky17 <joedonofry@gmail.com>2019-01-26 18:03:49 +0000
committerredsky17 <joedonofry@gmail.com>2019-01-26 18:03:49 +0000
commit6c31f5fe7a417ba904b7c31aa5065363a8f9d94b (patch)
tree3f2e9cb311f3f4cc951a616207fce65e99939518 /CMakeLists.txt
parentFix lint issue (diff)
downloadnheko-6c31f5fe7a417ba904b7c31aa5065363a8f9d94b.tar.xz
Add initial support for QtIndenticon
Add initial loading of qt jdenticon plugin:
https://github.com/redsky17/qt-jdenticon

Currently, the library's functionality has not been integrated
into the rest of nheko.  Next step is to add a configuration
item in the User Settings and use the plugin to generate
avatars for users without their own picture.  These avatars
should be cached in the Cache object.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 515e49d8..45a63829 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -282,6 +282,9 @@ include_directories(SYSTEM ${TWEENY_INCLUDE_DIR})
 include_directories(${CMAKE_SOURCE_DIR}/src)
 include_directories(${Boost_INCLUDE_DIRS})
 
+# local inclue directory
+include_directories(includes)
+
 qt5_wrap_cpp(MOC_HEADERS
     # Dialogs
     src/dialogs/CreateRoom.h