summary refs log tree commit diff
path: root/host/Rory-portable/postgres.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-portable/postgres.nix')
-rwxr-xr-xhost/Rory-portable/postgres.nix33
1 files changed, 0 insertions, 33 deletions
diff --git a/host/Rory-portable/postgres.nix b/host/Rory-portable/postgres.nix
deleted file mode 100755
index 7223f6a..0000000
--- a/host/Rory-portable/postgres.nix
+++ /dev/null
@@ -1,33 +0,0 @@
-{ pkgs, ... }:
-
-{
-  #systemd.tmpfiles.rules = [  "d /mnt/postgres/data 0750 postgres postgres" ];
-
-  services.postgresql = {
-    enable = true;
-    package = pkgs.postgresql_16;
-    enableTCPIP = true;
-    authentication = pkgs.lib.mkOverride 10 ''
-      # TYPE, DATABASE, USER, ADDRESS, METHOD
-      local all all trust
-      host all all 127.0.0.1/32 trust
-      host all all ::1/128 trust
-      host discordbots discordbots 192.168.1.2/32 trust
-      host matrix-synapse-rory-gay matrix-synapse-rory-gay 192.168.1.5/32 trust
-      host all all 0.0.0.0/0 md5
-    '';
-    # initialScript = pkgs.writeText "backend-initScript" ''
-    #   CREATE ROLE nixcloud WITH LOGIN PASSWORD 'nixcloud' CREATEDB;
-    #   CREATE DATABASE nixcloud;
-    #   GRANT ALL PRIVILEGES ON DATABASE nixcloud TO nixcloud;
-    # '';
-    #dataDir = "/mnt/postgres/data";
-    settings = {
-      "max_connections" = "100";
-      "shared_buffers" = "128MB";
-      "max_wal_size" = "1GB";
-      "min_wal_size" = "80MB";
-    };
-  };
-
-}