summary refs log tree commit diff
path: root/host/Rory-portable/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-portable/configuration.nix')
-rw-r--r--host/Rory-portable/configuration.nix64
1 files changed, 28 insertions, 36 deletions
diff --git a/host/Rory-portable/configuration.nix b/host/Rory-portable/configuration.nix
index 0c4fd6d..759379f 100644
--- a/host/Rory-portable/configuration.nix
+++ b/host/Rory-portable/configuration.nix
@@ -10,6 +10,7 @@
   imports = [
     ../../modules/base-client.nix
     ../../modules/packages/vim.nix
+    ./optional/gui/wayland.nix
   ];
 
   boot = {
@@ -74,23 +75,9 @@
     xserver = {
       enable = true;
       updateDbusEnvironment = true;
-      #videoDrivers = ["amdgpu"]; #"nvidia"
-      #desktopManager.gnome.enable = true;
       xkb.layout = "us";
-      windowManager.i3.enable = true;
-      windowManager.i3.extraSessionCommands = ''
-        # output from arandr:
-        #xrandr --output DP-1 --mode 1920x1080 --pos 3840x1080 --rotate normal --output HDMI-1 --mode 3840x2160 --pos 0x0 --rotate normal --output HDMI-2 --off --output DP-2 --off
-        #xrandr --output HDMI-1 --mode 3840x2160 --pos 0x0 --rotate normal --primary --output DP-1 --mode 1920x1080 --pos 3840x1080 --rotate normal --output HDMI-2 --off --output DP-2 --off
-        ${pkgs.polybarFull}/bin/polybar &
-        ${pkgs.dunst}/bin/dunst &
-        ${pkgs.feh}/bin/feh --no-fehbg --bg-fill ${../../modules/users/Rory/wallpaper.webp}
-      '';
     };
     libinput.enable = true;
-    picom.enable = true;
-    picom.vSync = false;
-    picom.backend = "glx";
 
     openssh = {
       enable = true;
@@ -116,32 +103,32 @@
     feh
     easyeffects
     kitty
-    youtube-music
+    #youtube-music
 
     # - IDEs
     #jetbrains-toolbox
-    jetbrains.rider
+    #jetbrains.rider
     #jetbrains.webstorm
     #jetbrains.clion
-    github-copilot-intellij-agent
+    #github-copilot-intellij-agent
 
-    dbeaver-bin
+    #dbeaver-bin
     #insomnia
-    vscode
+    #vscode
 
     # - Utilities
-    inkscape-with-extensions
-    gimp # -with-plugins
+    #inkscape-with-extensions
+    #gimp # -with-plugins
 
     # - Languages
     #dotnet-sdk_7
-    dotnet-sdk_8
+    #dotnet-sdk_8
     #(callPackage ../../modules/packages/dotnet-pack.nix { inherit pkgs; })
 
     #games
-    osu-lazer-bin
+    #osu-lazer-bin
     #steam
-    steam-run
+    #steam-run
 
     # extra packages
     dmenu
@@ -149,9 +136,7 @@
     nemo
     file-roller
     firefox-bin
-    ungoogled-chromium # needed for Rider in order to debug WASM
-
-    peek
+    #ungoogled-chromium # needed for Rider in order to debug WASM
 
     unrar-wrapper
 
@@ -170,8 +155,8 @@
     # (dwarf-fortress-packages.dwarf-fortress-full.override { enableStoneSense = true; enableFPS = true; theme = dwarf-fortress-packages.themes.spacefox; })
   ];
 
-  programs.steam.enable = true;
-  programs.steam.gamescopeSession.enable = true;
+  #programs.steam.enable = true;
+  #programs.steam.gamescopeSession.enable = true;
 
   #environment.gnome.excludePackages = [
   #  pkgs.orca
@@ -180,12 +165,11 @@
   #];
   xdg = {
     portal = {
-
       enable = true;
       extraPortals = with pkgs; [
         #xdg-desktop-portal-gtk
         xdg-desktop-portal-xapp
-        (callPackage ../../modules/packages/xdg-desktop-portal-gtk.nix { })
+#        (callPackage ../../modules/packages/xdg-desktop-portal-gtk.nix { })
       ];
       config = {
         common = {
@@ -193,8 +177,6 @@
         };
       };
       xdgOpenUsePortal = true;
-      #gtkUsePortal = true;
-
     };
     #sounds.enable = true;
     #mime.enable = true;
@@ -203,7 +185,7 @@
     #autostart.enable = true;
   };
   fonts = {
-    fonts = with pkgs; [
+    packages = with pkgs; [
       (nerdfonts.override { fonts = [ "JetBrainsMono" ]; })
       noto-fonts-monochrome-emoji
     ];
@@ -229,8 +211,18 @@
   #};
   # };
 
-  virtualisation.libvirtd.enable = true;
-  programs.virt-manager.enable = true;
+  #virtualisation.libvirtd.enable = true;
+  #programs.virt-manager.enable = true;
 
   system.stateVersion = "22.11"; # DO NOT EDIT!
+
+  nixpkgs = {
+    config = {
+      allowUnfree = true;
+      permittedInsecurePackages = [
+        "electron-25.9.0"
+        "olm-3.2.16"
+      ];
+    };
+  };
 }