summary refs log tree commit diff
path: root/modules/users/chris.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/users/chris.nix')
-rwxr-xr-xmodules/users/chris.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/modules/users/chris.nix b/modules/users/chris.nix
new file mode 100755
index 0000000..bbb4eba
--- /dev/null
+++ b/modules/users/chris.nix
@@ -0,0 +1,14 @@
+{ config, pkgs, ... }:
+{
+  users.users.chris = {
+    isNormalUser = true;
+    extraGroups = [ "wheel" ];
+    packages = with pkgs; [
+      nano
+    ];
+    openssh.authorizedKeys.keys = [
+      "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIMd9U0+wKjBG3Q9Qg249xJY+ybYeRV9/VMPjuwKvFBEI"
+    ];
+  };
+}
+