summary refs log tree commit diff
path: root/modules/infra-logs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/infra-logs.nix')
-rw-r--r--modules/infra-logs.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/modules/infra-logs.nix b/modules/infra-logs.nix
new file mode 100644
index 0000000..0ca78a0
--- /dev/null
+++ b/modules/infra-logs.nix
@@ -0,0 +1,16 @@
+{ config, pkgs, lib, secrets, ... }:
+{
+  systemd.services = {
+    "boot" = {
+        wantedBy = [ "multi-user.target" ];
+        serviceConfig = {
+            ExecStart = ''
+              ${pkgs.curl}/bin/curl -H "Content-Type: application/json" -d '{"username": "${config.networking.hostName}", "content": "System booted."}' ${secrets.webhooks.discord.deploy}
+              '';
+            #Restart = "never";
+            User = "root";
+        };
+    };
+  };
+}
+