summary refs log tree commit diff
path: root/modules/auto-redeploy.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/auto-redeploy.nix')
-rw-r--r--modules/auto-redeploy.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/modules/auto-redeploy.nix b/modules/auto-redeploy.nix
new file mode 100644
index 0000000..c49399c
--- /dev/null
+++ b/modules/auto-redeploy.nix
@@ -0,0 +1,30 @@
+{ config, pkgs, lib, secrets, ... }:
+{
+  systemd.services = {
+    "auto-redeploy" = {
+        wantedBy = [ "multi-user.target" ];
+        after = [ "network.target" ];
+        serviceConfig = {
+            ExecStart = ''
+              ${pkgs.curl}/bin/curl -H "Content-Type: application/json" -d '{"username": "${config.networking.hostName} - redeploy", "content": "System started redeploy."}' ${secrets.webhooks.discord.deploy}
+              cd /Spacebar-Open-Architecture
+              #store current commit hash
+              currentCommit=$(git rev-parse HEAD)
+              #pull from git, and exit if nothing to pull
+              ${pkgs.git}/bin/git pull || exit 0
+              #send commit log to discord
+              ${pkgs.curl}/bin/curl -H "Content-Type: application/json" -d '{"username": "${config.networking.hostName} - redeploy", "content": "```$(git log --pretty=format:"%h - %s" $currentCommit..HEAD)```"}' ${secrets.webhooks.discord.deploy}
+              #call ./update.sh and store output (including stderr) in a file
+              ./update.sh 2>&1 | tee /tmp/update.log
+              #send the output to discord as a file
+              ${pkgs.curl}/bin/curl -F "file=@/tmp/update.log" -F "filename=update.log" -F "content=System finished redeploy." -H "Content-Type: multipart/form-data" ${secrets.webhooks.discord.deploy}
+              
+              '';
+            #Restart = "never";
+            User = "root";
+        };
+    };
+  };
+}
+
+