summary refs log tree commit diff
path: root/host/Spacebar-nginx/nginx-hosts/thearcanebrony.net/matrix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Spacebar-nginx/nginx-hosts/thearcanebrony.net/matrix.nix')
-rwxr-xr-xhost/Spacebar-nginx/nginx-hosts/thearcanebrony.net/matrix.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/host/Spacebar-nginx/nginx-hosts/thearcanebrony.net/matrix.nix b/host/Spacebar-nginx/nginx-hosts/thearcanebrony.net/matrix.nix
new file mode 100755
index 0000000..d2b7606
--- /dev/null
+++ b/host/Spacebar-nginx/nginx-hosts/thearcanebrony.net/matrix.nix
@@ -0,0 +1,14 @@
+{
+  enableACME = true;
+  addSSL = true;
+  locations = {
+    "/" = {
+      proxyPass = "http://192.168.1.200:8008";
+      proxyWebsockets = true;
+      extraConfig =
+        "proxy_ssl_server_name on;" +
+        "proxy_pass_header Authorization;"
+        ;
+    };
+  };
+}