summary refs log tree commit diff
path: root/host/Spacebar-nginx/nginx-hosts/spacebar.chat/server/old/cdn.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Spacebar-nginx/nginx-hosts/spacebar.chat/server/old/cdn.nix')
-rwxr-xr-xhost/Spacebar-nginx/nginx-hosts/spacebar.chat/server/old/cdn.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/host/Spacebar-nginx/nginx-hosts/spacebar.chat/server/old/cdn.nix b/host/Spacebar-nginx/nginx-hosts/spacebar.chat/server/old/cdn.nix
new file mode 100755
index 0000000..89958fe
--- /dev/null
+++ b/host/Spacebar-nginx/nginx-hosts/spacebar.chat/server/old/cdn.nix
@@ -0,0 +1,14 @@
+{
+  enableACME = true;
+  forceSSL = true;
+  locations = {
+    "/" = {
+      proxyPass = "http://192.168.1.200:3003";
+      proxyWebsockets = true;
+      extraConfig =
+        "proxy_ssl_server_name on;" +
+        "proxy_pass_header Authorization;"
+        ;
+    };
+  };
+}