summary refs log tree commit diff
path: root/host/Spacebar-nginx/nginx-hosts/spacebar.chat/mail.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Spacebar-nginx/nginx-hosts/spacebar.chat/mail.nix')
-rwxr-xr-xhost/Spacebar-nginx/nginx-hosts/spacebar.chat/mail.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/host/Spacebar-nginx/nginx-hosts/spacebar.chat/mail.nix b/host/Spacebar-nginx/nginx-hosts/spacebar.chat/mail.nix
new file mode 100755
index 0000000..3ca873d
--- /dev/null
+++ b/host/Spacebar-nginx/nginx-hosts/spacebar.chat/mail.nix
@@ -0,0 +1,14 @@
+{
+  enableACME = true;
+  forceSSL = true;
+  locations = {
+    "/" = {
+      proxyPass = "http://192.168.1.3";
+      proxyWebsockets = true;
+      extraConfig =
+        "proxy_ssl_server_name on;" +
+        "proxy_pass_header Authorization;"
+        ;
+    };
+  };
+}