summary refs log tree commit diff
path: root/host/Spacebar-nginx/nginx-hosts/spacebar.chat/internal/secrets.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Spacebar-nginx/nginx-hosts/spacebar.chat/internal/secrets.nix')
-rw-r--r--host/Spacebar-nginx/nginx-hosts/spacebar.chat/internal/secrets.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/host/Spacebar-nginx/nginx-hosts/spacebar.chat/internal/secrets.nix b/host/Spacebar-nginx/nginx-hosts/spacebar.chat/internal/secrets.nix
new file mode 100644
index 0000000..cc0e299
--- /dev/null
+++ b/host/Spacebar-nginx/nginx-hosts/spacebar.chat/internal/secrets.nix
@@ -0,0 +1,20 @@
+{ lib, config }: {
+  root = "/data/nginx/secrets";
+  #use ip from ens18
+  listenAddresses = [ 
+    (lib.head config.networking.interfaces.ens18.ipv4.addresses).address
+   ];
+  locations = {
+    "/" = {
+      extraConfig =
+        "autoindex on;" + 
+        "allow 192.168.1.0/24;" +
+        "allow 127.0.0.1;" +
+        "deny all;"
+        ;
+    };
+    "^~ /.well-known/acme-challenge/" = {
+      root = "/var/lib/acme/acme-challenge";
+    };
+  };
+}