summary refs log tree commit diff
path: root/host/Spacebar-nginx/nginx-hosts/fosscord.com/root.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Spacebar-nginx/nginx-hosts/fosscord.com/root.nix')
-rw-r--r--host/Spacebar-nginx/nginx-hosts/fosscord.com/root.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/host/Spacebar-nginx/nginx-hosts/fosscord.com/root.nix b/host/Spacebar-nginx/nginx-hosts/fosscord.com/root.nix
new file mode 100644
index 0000000..7efa326
--- /dev/null
+++ b/host/Spacebar-nginx/nginx-hosts/fosscord.com/root.nix
@@ -0,0 +1,16 @@
+{ lib, config }: {  
+  locations = {
+    "/" = {
+      extraConfig =
+        ''
+        return 301 https://spacebar.chat$request_uri;
+        '';
+    };
+    ".well-known/matrix/server" = {
+      root = "/var/lib/matrix";
+    };
+    "^~ /.well-known/acme-challenge/" = {
+      root = "/var/lib/acme/acme-challenge";
+    };
+  };
+}