summary refs log tree commit diff
path: root/host/Spacebar-nginx/hosts/spacebar.local/secrets.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Spacebar-nginx/hosts/spacebar.local/secrets.nix')
-rw-r--r--host/Spacebar-nginx/hosts/spacebar.local/secrets.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/host/Spacebar-nginx/hosts/spacebar.local/secrets.nix b/host/Spacebar-nginx/hosts/spacebar.local/secrets.nix
new file mode 100644
index 0000000..d52d481
--- /dev/null
+++ b/host/Spacebar-nginx/hosts/spacebar.local/secrets.nix
@@ -0,0 +1,17 @@
+{ lib, config }: {
+  root = "/data/nginx/secrets";
+  #use ip from ens18
+  listenAddresses = [ 
+    (lib.head config.networking.interfaces.ens18.ipv4.addresses).address
+   ];
+  locations = {
+    "/" = {
+      extraConfig =
+        "autoindex on;" + 
+        "allow 192.168.1.0/24;" +
+        "allow 127.0.0.1;" +
+        "deny all;"
+        ;
+    };
+  };
+}