summary refs log tree commit diff
path: root/host/Spacebar-nginx/containers/spacebar-server/root.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Spacebar-nginx/containers/spacebar-server/root.nix')
-rwxr-xr-xhost/Spacebar-nginx/containers/spacebar-server/root.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/host/Spacebar-nginx/containers/spacebar-server/root.nix b/host/Spacebar-nginx/containers/spacebar-server/root.nix
new file mode 100755
index 0000000..d543ef2
--- /dev/null
+++ b/host/Spacebar-nginx/containers/spacebar-server/root.nix
@@ -0,0 +1,32 @@
+{ config, pkgs, lib, ... }:
+
+{
+  imports =
+    [
+      ./services/nginx.nix
+      ./services/spacebar-server.nix
+      ./services/postgres.nix
+    ];
+
+  environment.systemPackages = with pkgs; [
+    wget
+    neofetch
+    lnav
+    zsh
+    git
+    lsd
+    htop
+    btop
+    duf
+    kitty.terminfo
+    neovim
+    tmux
+    jq
+    yq
+    pv
+    dig
+    cloud-utils
+    neovim
+  ];
+  system.stateVersion = "22.11"; # DO NOT EDIT!
+}
\ No newline at end of file