summary refs log tree commit diff
path: root/host/Spacebar-nginx/containers/spacebar-server-dev-nix/container.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Spacebar-nginx/containers/spacebar-server-dev-nix/container.nix')
-rwxr-xr-xhost/Spacebar-nginx/containers/spacebar-server-dev-nix/container.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/host/Spacebar-nginx/containers/spacebar-server-dev-nix/container.nix b/host/Spacebar-nginx/containers/spacebar-server-dev-nix/container.nix
new file mode 100755
index 0000000..bed6690
--- /dev/null
+++ b/host/Spacebar-nginx/containers/spacebar-server-dev-nix/container.nix
@@ -0,0 +1,24 @@
+{ pkgs, lib, spacebar-server, ... }:
+
+{
+  privateNetwork = true;
+  autoStart = true;
+  specialArgs = {
+    inherit spacebar-server;
+  };  
+  config = { lib, pkgs, spacebar-server, ... }: {
+    imports = [ ./root.nix ];
+    environment.etc."resolv.conf".text = ''
+      nameserver 8.8.8.8
+      nameserver 8.4.4.8
+      nameserver 1.1.1.1
+      nameserver 1.0.0.1
+      '';
+    networking.firewall = {
+      enable = true;
+      allowedTCPPorts = [ 80 ];
+    };
+  };  
+  hostAddress = "192.168.101.1";
+  localAddress = "192.168.100.1";
+}
\ No newline at end of file