summary refs log tree commit diff
path: root/host/Spacebar-nginx/hosts/thearcanebrony.net/matrix.nix
diff options
context:
space:
mode:
authorTheArcaneBrony <myrainbowdash949@gmail.com>2023-04-03 19:49:31 +0200
committerRory& <root@rory.gay>2024-06-05 17:24:45 +0200
commit52986029006a7ed4db7801bf394335318f07097f (patch)
tree8a40001e1e1c20cccb897941eec86bfda7827162 /host/Spacebar-nginx/hosts/thearcanebrony.net/matrix.nix
parentPort update script to service (diff)
downloadSpacebar-Open-Infrastructure-52986029006a7ed4db7801bf394335318f07097f.tar.xz
Add tab matrix proxy
Diffstat (limited to 'host/Spacebar-nginx/hosts/thearcanebrony.net/matrix.nix')
-rwxr-xr-xhost/Spacebar-nginx/hosts/thearcanebrony.net/matrix.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/host/Spacebar-nginx/hosts/thearcanebrony.net/matrix.nix b/host/Spacebar-nginx/hosts/thearcanebrony.net/matrix.nix
new file mode 100755
index 0000000..d2b7606
--- /dev/null
+++ b/host/Spacebar-nginx/hosts/thearcanebrony.net/matrix.nix
@@ -0,0 +1,14 @@
+{
+  enableACME = true;
+  addSSL = true;
+  locations = {
+    "/" = {
+      proxyPass = "http://192.168.1.200:8008";
+      proxyWebsockets = true;
+      extraConfig =
+        "proxy_ssl_server_name on;" +
+        "proxy_pass_header Authorization;"
+        ;
+    };
+  };
+}