summary refs log tree commit diff
path: root/host/Spacebar-nginx/containers/spacebar-server/container.nix
diff options
context:
space:
mode:
authorRory& <root@rory.gay>2024-02-19 11:18:45 +0100
committerRory& <root@rory.gay>2024-06-05 17:25:16 +0200
commit7720ba2a8c17e31ea303e5b5c72bf8239d65c6c0 (patch)
tree3b7c1094a10b7dd8b3562debd8c9c72cf0d8cfd8 /host/Spacebar-nginx/containers/spacebar-server/container.nix
parentSwitch dev/nix instance to master (diff)
downloadSpacebar-Open-Infrastructure-7720ba2a8c17e31ea303e5b5c72bf8239d65c6c0.tar.xz
Fix container folder name
Diffstat (limited to 'host/Spacebar-nginx/containers/spacebar-server/container.nix')
-rwxr-xr-xhost/Spacebar-nginx/containers/spacebar-server/container.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/host/Spacebar-nginx/containers/spacebar-server/container.nix b/host/Spacebar-nginx/containers/spacebar-server/container.nix
new file mode 100755
index 0000000..7882f72
--- /dev/null
+++ b/host/Spacebar-nginx/containers/spacebar-server/container.nix
@@ -0,0 +1,25 @@
+{ pkgs, lib, spacebar-server, rootDomain, ... }:
+
+{
+  privateNetwork = true;
+  autoStart = true;
+  specialArgs = {
+    inherit spacebar-server;
+    inherit rootDomain;
+  };  
+  config = { lib, pkgs, spacebar-server, rootDomain, ... }: {
+    imports = [ ./root.nix ];
+    environment.etc."resolv.conf".text = ''
+      nameserver 8.8.8.8
+      nameserver 8.4.4.8
+      nameserver 1.1.1.1
+      nameserver 1.0.0.1
+      '';
+    networking.firewall = {
+      enable = true;
+      allowedTCPPorts = [ 80 5432 ];
+    };
+  };  
+  hostAddress = "192.168.101.1";
+  localAddress = "192.168.100.1";
+}
\ No newline at end of file