summary refs log tree commit diff
path: root/host/Spacebar-nginx/containers/spacebar-server-dev-nix/root.nix
diff options
context:
space:
mode:
authorTheArcaneBrony <myrainbowdash949@gmail.com>2023-09-25 22:01:30 +0200
committerRory& <root@rory.gay>2024-06-05 17:25:16 +0200
commit6ad94061571c1abf39cb81903fefd773f8d8941c (patch)
tree70201c3d2d4721664e909f1a1462551e8aa83fc0 /host/Spacebar-nginx/containers/spacebar-server-dev-nix/root.nix
parentSwitch to nginx mainline (diff)
downloadSpacebar-Open-Infrastructure-6ad94061571c1abf39cb81903fefd773f8d8941c.tar.xz
Work on spacebar container
Squashed 36
Diffstat (limited to 'host/Spacebar-nginx/containers/spacebar-server-dev-nix/root.nix')
-rwxr-xr-xhost/Spacebar-nginx/containers/spacebar-server-dev-nix/root.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/host/Spacebar-nginx/containers/spacebar-server-dev-nix/root.nix b/host/Spacebar-nginx/containers/spacebar-server-dev-nix/root.nix
new file mode 100755
index 0000000..bb005f9
--- /dev/null
+++ b/host/Spacebar-nginx/containers/spacebar-server-dev-nix/root.nix
@@ -0,0 +1,31 @@
+{ config, pkgs, lib, ... }:
+
+{
+  imports =
+    [
+      ./services/nginx.nix
+      ./services/spacebar-server.nix
+    ];
+
+  environment.systemPackages = with pkgs; [
+    wget
+    neofetch
+    lnav
+    zsh
+    git
+    lsd
+    htop
+    btop
+    duf
+    kitty.terminfo
+    neovim
+    tmux
+    jq
+    yq
+    pv
+    dig
+    cloud-utils
+    neovim
+  ];
+  system.stateVersion = "22.11"; # DO NOT EDIT!
+}
\ No newline at end of file