summary refs log tree commit diff
path: root/host/Spacebar-nginx/containers/spacebar-server-dev-nix/import.nix
diff options
context:
space:
mode:
authorRory& <root@rory.gay>2024-02-19 11:18:45 +0100
committerRory& <root@rory.gay>2024-06-05 17:25:16 +0200
commit7720ba2a8c17e31ea303e5b5c72bf8239d65c6c0 (patch)
tree3b7c1094a10b7dd8b3562debd8c9c72cf0d8cfd8 /host/Spacebar-nginx/containers/spacebar-server-dev-nix/import.nix
parentSwitch dev/nix instance to master (diff)
downloadSpacebar-Open-Infrastructure-7720ba2a8c17e31ea303e5b5c72bf8239d65c6c0.tar.xz
Fix container folder name
Diffstat (limited to 'host/Spacebar-nginx/containers/spacebar-server-dev-nix/import.nix')
-rw-r--r--host/Spacebar-nginx/containers/spacebar-server-dev-nix/import.nix50
1 files changed, 0 insertions, 50 deletions
diff --git a/host/Spacebar-nginx/containers/spacebar-server-dev-nix/import.nix b/host/Spacebar-nginx/containers/spacebar-server-dev-nix/import.nix
deleted file mode 100644
index 7be8e2d..0000000
--- a/host/Spacebar-nginx/containers/spacebar-server-dev-nix/import.nix
+++ /dev/null
@@ -1,50 +0,0 @@
-{ 
-  config,
-  pkgs,
-  lib,
-  secrets,
-  spacebar-server,
-  containerName,
-  rootDomain,
-  ...
-}:
-
-{
-  containers."${containerName}" = import ./container.nix {
-    inherit pkgs lib spacebar-server rootDomain;
-  };
-
-  security.acme.certs."${rootDomain}" = {
-    domain = "${rootDomain}";
-    extraDomainNames = [ "*.${rootDomain}" ];
-    group = "nginx";
-    dnsProvider = "cloudflare";
-    credentialsFile = pkgs.writeTextFile {
-      name = "cloudflare-credentials";
-      text = ''
-        # Cloudflare API credentials used by lego
-        # https://go-acme.github.io/lego/dns/cloudflare/
-        CLOUDFLARE_DNS_API_TOKEN=${secrets.secret_keys.cloudflare_dns}
-      '';
-    };
-  };
-
-  services.nginx.virtualHosts."*.${rootDomain}" = {
-    serverName = "*.${rootDomain}";
-    useACMEHost = "${rootDomain}";
-    forceSSL = true;
-    locations."/" = {
-      proxyPass = "http://${containerName}.containers";
-    };
-  };
-  services.nginx.virtualHosts."${rootDomain}" = {
-    serverName = "${rootDomain}";
-    useACMEHost = "${rootDomain}";
-    forceSSL = true;
-    locations."/" = {
-      proxyPass = "http://${containerName}.containers";
-    };
-  };
-
-  system.stateVersion = "22.11"; # DO NOT EDIT!
-}
\ No newline at end of file