summary refs log tree commit diff
path: root/host/Spacebar-nginx/configuration.nix
diff options
context:
space:
mode:
authorTheArcaneBrony <myrainbowdash949@gmail.com>2023-09-26 15:03:18 +0200
committerRory& <root@rory.gay>2024-06-05 17:25:16 +0200
commit10a409f984e9bce9cf15c1aaf3771a5043afc305 (patch)
tree0c8b07784e7632a5c9b53ef3ddedb5bdbae067ab /host/Spacebar-nginx/configuration.nix
parentWork on spacebar container (diff)
downloadSpacebar-Open-Infrastructure-10a409f984e9bce9cf15c1aaf3771a5043afc305.tar.xz
Postgres, maybe?
Diffstat (limited to 'host/Spacebar-nginx/configuration.nix')
-rwxr-xr-xhost/Spacebar-nginx/configuration.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/host/Spacebar-nginx/configuration.nix b/host/Spacebar-nginx/configuration.nix
index 56b5bf1..434b2ff 100755
--- a/host/Spacebar-nginx/configuration.nix
+++ b/host/Spacebar-nginx/configuration.nix
@@ -26,6 +26,13 @@
       recommendedProxySettings = true;
       recommendedTlsSettings = true;
       clientMaxBodySize = "50m";
+      appendConfig = ''
+        worker_processes 16;
+        '';
+      eventsConfig = ''
+        #use kqueue;
+        worker_connections 512;
+        '';
       virtualHosts = {
         # legacy
         "matrix.thearcanebrony.net" = import ./nginx-hosts/thearcanebrony.net/matrix.nix;
@@ -44,6 +51,11 @@
       };
     };
   };
+
+  systemd.services.nginx.serviceConfig = {
+    LimitNOFILE=5000000;
+  };
+
   systemd.services.nginx.requires = [ "data.mount" ];
   security.acme.acceptTerms = true;
   security.acme.defaults.email = "chris@spacebar.chat";