summary refs log tree commit diff
path: root/rtc/CMakeLists.txt
diff options
context:
space:
mode:
authorMadeline <46743919+MaddyUnderStars@users.noreply.github.com>2022-09-25 18:24:21 +1000
committerMadeline <46743919+MaddyUnderStars@users.noreply.github.com>2022-09-25 23:35:18 +1000
commitf44f5d7ac2d24ff836c2e1d4b2fa58da04b13052 (patch)
treea6655c41bb3db79c30fd876b06ee60fe9cf70c9b /rtc/CMakeLists.txt
parentAllow edited_timestamp to passthrough in handleMessage (diff)
downloadserver-f44f5d7ac2d24ff836c2e1d4b2fa58da04b13052.tar.xz
Refactor to mono-repo + upgrade packages
Diffstat (limited to 'rtc/CMakeLists.txt')
-rw-r--r--rtc/CMakeLists.txt16
1 files changed, 0 insertions, 16 deletions
diff --git a/rtc/CMakeLists.txt b/rtc/CMakeLists.txt
deleted file mode 100644
index 2cf5c0a6..00000000
--- a/rtc/CMakeLists.txt
+++ /dev/null
@@ -1,16 +0,0 @@
-cmake_minimum_required(VERSION 3.2)
-project(fosscord-media)
-
-set(CMAKE_CXX_STANDARD 17)
-
-find_package(Threads REQUIRED)
-
-find_package(mongocxx REQUIRED)
-find_package(Boost REQUIRED)
-
-
-file(GLOB SourceFiles ${PROJECT_SOURCE_DIR}/src/*.cpp)
-#include_directories("bsoncxx/v_noabi/bsoncxx/")
-add_executable(${CMAKE_PROJECT_NAME} ${SourceFiles})
-
-target_link_libraries(${CMAKE_PROJECT_NAME} datachannel mongo::mongocxx_shared Boost::boost)
\ No newline at end of file