summary refs log tree commit diff
path: root/rtc/CMakeLists.txt
diff options
context:
space:
mode:
authorFlam3rboy <34555296+Flam3rboy@users.noreply.github.com>2021-08-12 20:33:42 +0200
committerFlam3rboy <34555296+Flam3rboy@users.noreply.github.com>2021-08-12 20:33:42 +0200
commit613ef19d2119449d516555ea2d2036d7f98c298d (patch)
tree30c22d96aea3da6f859a4690ce9fadcc97cddc3c /rtc/CMakeLists.txt
parent:sparkles: util (diff)
downloadserver-613ef19d2119449d516555ea2d2036d7f98c298d.tar.xz
:sparkles: rtc
Diffstat (limited to 'rtc/CMakeLists.txt')
-rw-r--r--rtc/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/rtc/CMakeLists.txt b/rtc/CMakeLists.txt
new file mode 100644
index 00000000..2cf5c0a6
--- /dev/null
+++ b/rtc/CMakeLists.txt
@@ -0,0 +1,16 @@
+cmake_minimum_required(VERSION 3.2)
+project(fosscord-media)
+
+set(CMAKE_CXX_STANDARD 17)
+
+find_package(Threads REQUIRED)
+
+find_package(mongocxx REQUIRED)
+find_package(Boost REQUIRED)
+
+
+file(GLOB SourceFiles ${PROJECT_SOURCE_DIR}/src/*.cpp)
+#include_directories("bsoncxx/v_noabi/bsoncxx/")
+add_executable(${CMAKE_PROJECT_NAME} ${SourceFiles})
+
+target_link_libraries(${CMAKE_PROJECT_NAME} datachannel mongo::mongocxx_shared Boost::boost)
\ No newline at end of file