about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorTheArcaneBrony <myrainbowdash949@gmail.com>2023-10-10 21:24:28 +0200
committerEmma [it/its]@Rory& <root@rory.gay>2023-10-10 21:44:30 +0200
commit06be7bed0c640c21503f75ce834a6fde2fc905ba (patch)
treeeff4ef92267dd79ce308ec2df348ae6ef50e8ecc /flake.nix
downloadOsuFederatedBeatmapApi-06be7bed0c640c21503f75ce834a6fde2fc905ba.tar.xz
Initial commit
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..851a880
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,28 @@
+{
+  inputs.nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
+  #inputs.nixpkgs.url = "path:/home/root@Rory/git/Matrix/MatrixRoomUtils/nixpkgs";
+  inputs.flake-utils.url = "github:numtide/flake-utils";
+
+  outputs = { self, nixpkgs, flake-utils }:
+      let
+        pkgs = nixpkgs.legacyPackages.x86_64-linux;
+      in
+      {
+         packages.x86_64-linux = {
+            default = pkgs.buildDotnetModule rec {
+              pname = "OsuFederatedBeatmapApi-v${version}";
+              version = "1";
+              dotnet-sdk = pkgs.dotnet-sdk_7;
+              dotnet-runtime = pkgs.dotnet-aspnetcore_7;
+              src = ./.;
+              projectFile = [
+                "OsuFederatedBeatmapApi/OsuFederatedBeatmapApi.csproj"
+               ];
+              nugetDeps = OsuFederatedBeatmapApi/deps.nix;
+              #nativeBuildInputs = with pkgs; [
+              #  pkg-config
+              #];
+            };
+        };
+    };
+}