about summary refs log tree commit diff
path: root/ModerationClient/flake.nix
diff options
context:
space:
mode:
authorRory& <root@rory.gay>2025-03-12 04:44:19 +0100
committerRory& <root@rory.gay>2025-03-12 04:44:19 +0100
commit1a224441228d07440f279ce4a15c9a043b8cda6d (patch)
tree3ea4f4e2b694bf4a64079b084ea41d3c363937bb /ModerationClient/flake.nix
parentVarious work (diff)
downloadModerationClient-1a224441228d07440f279ce4a15c9a043b8cda6d.tar.xz
Part of event rendering
Diffstat (limited to 'ModerationClient/flake.nix')
-rw-r--r--ModerationClient/flake.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/ModerationClient/flake.nix b/ModerationClient/flake.nix
new file mode 100644

index 0000000..6c55fde --- /dev/null +++ b/ModerationClient/flake.nix
@@ -0,0 +1,37 @@ +{ + description = ".NET project template"; + + inputs = { + nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable"; + utils.url = "github:numtide/flake-utils"; + }; + + outputs = inputs@{ nixpkgs, ... }: + inputs.utils.lib.eachDefaultSystem (system: + let + pkgs = import nixpkgs { inherit system; }; + xorgLibs = with pkgs.xorg; [ + libICE + libSM + libX11 + libX11.dev + ]; + in + rec { + # `nix develop` + devShells.default = with pkgs; mkShell { + buildInputs = [ + dotnetCorePackages.dotnet_9.sdk + fontconfig + gnumake + icu + openssl + ] ++ xorgLibs; + + shellHook = '' + export DOTNET_ROOT=${dotnet-sdk} + export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:${lib.makeLibraryPath ([ fontconfig icu openssl ] ++ xorgLibs) } + ''; + }; + }); +} \ No newline at end of file