1 files changed, 6 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index b9d490adc9..5baf2475f0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -51,5 +51,11 @@ override_dh_shlibdeps:
override_dh_virtualenv:
./debian/build_virtualenv
+override_dh_builddeb:
+ # force the compression to xzip, to stop dpkg-deb on impish defaulting to zstd
+ # (which requires reprepro 5.3.0-1.3, which is currently only in 'experimental' in Debian:
+ # https://metadata.ftp-master.debian.org/changelogs/main/r/reprepro/reprepro_5.3.0-1.3_changelog)
+ dh_builddeb -- -Zxz
+
%:
dh $@ --with python-virtualenv
|