summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorAndrew Morgan <andrew@amorgan.xyz>2020-10-21 14:15:38 +0100
committerAndrew Morgan <andrew@amorgan.xyz>2020-10-21 14:15:38 +0100
commit3729b15a64ab8c07c617211634e089ce7cb65bfb (patch)
tree8b2edfae721c38cade17333a840ed09540aa05ba /setup.py
parentMerge commit '4325be1a5' into anoa/dinsic_release_1_21_x (diff)
parentFactor out `_send_dummy_event_for_room` (#8370) (diff)
downloadsynapse-3729b15a64ab8c07c617211634e089ce7cb65bfb.tar.xz
Merge commit '2983049a7' into anoa/dinsic_release_1_21_x
* commit '2983049a7':
  Factor out `_send_dummy_event_for_room` (#8370)
  Improve logging of state resolution (#8371)
  Fix bug which caused failure on join with malformed membership events (#8385)
  Use `async with` for ID gens (#8383)
  Don't push if an user account has expired (#8353)
  Do not check lint/test dependencies at runtime. (#8377)
  Add note to reverse_proxy.md about disabling Apache's mod_security2 (#8375)
  Changelog
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py16
1 files changed, 16 insertions, 0 deletions
diff --git a/setup.py b/setup.py

index 54ddec8f9f..926b1bc86f 100755 --- a/setup.py +++ b/setup.py
@@ -94,6 +94,22 @@ ALL_OPTIONAL_REQUIREMENTS = dependencies["ALL_OPTIONAL_REQUIREMENTS"] # Make `pip install matrix-synapse[all]` install all the optional dependencies. CONDITIONAL_REQUIREMENTS["all"] = list(ALL_OPTIONAL_REQUIREMENTS) +# Developer dependencies should not get included in "all". +# +# We pin black so that our tests don't start failing on new releases. +CONDITIONAL_REQUIREMENTS["lint"] = [ + "isort==5.0.3", + "black==19.10b0", + "flake8-comprehensions", + "flake8", +] + +# Dependencies which are exclusively required by unit test code. This is +# NOT a list of all modules that are necessary to run the unit tests. +# Tests assume that all optional dependencies are installed. +# +# parameterized_class decorator was introduced in parameterized 0.7.0 +CONDITIONAL_REQUIREMENTS["test"] = ["mock>=2.0", "parameterized>=0.7.0"] setup( name="matrix-synapse",