summary refs log tree commit diff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorPatrick Cloke <patrickc@matrix.org>2022-10-14 14:11:27 -0400
committerPatrick Cloke <patrickc@matrix.org>2022-10-14 14:11:27 -0400
commitbc2bd92b930288f3c4bb08a72d8dba24d7416ffd (patch)
treefffa5bb099b5aa81e27a9b663a22bd57cc3300fe /pyproject.toml
parentAccept threaded receipts for events related to the root event. (#14174) (diff)
parent1.69.0rc4 (diff)
downloadsynapse-bc2bd92b930288f3c4bb08a72d8dba24d7416ffd.tar.xz
Merge remote-tracking branch 'origin/release-v1.69' into develop
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml13
1 files changed, 9 insertions, 4 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 3dc4b66ca9..4f6c919c96 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -57,7 +57,7 @@ manifest-path = "rust/Cargo.toml"
 
 [tool.poetry]
 name = "matrix-synapse"
-version = "1.69.0rc2"
+version = "1.69.0rc4"
 description = "Homeserver for the Matrix decentralised comms protocol"
 authors = ["Matrix.org Team and Contributors <packages@matrix.org>"]
 license = "Apache-2.0"
@@ -219,7 +219,7 @@ oidc = ["authlib"]
 # `systemd.journal.JournalHandler`, as is documented in
 # `contrib/systemd/log_config.yaml`.
 systemd = ["systemd-python"]
-url_preview = ["lxml"]
+url-preview = ["lxml"]
 sentry = ["sentry-sdk"]
 opentracing = ["jaeger-client", "opentracing"]
 jwt = ["authlib"]
@@ -250,7 +250,7 @@ all = [
     "pysaml2",
     # oidc and jwt
     "authlib",
-    # url_preview
+    # url-preview
     "lxml",
     # sentry
     "sentry-sdk",
@@ -307,7 +307,12 @@ twine = "*"
 towncrier = ">=18.6.0rc1"
 
 [build-system]
-requires = ["poetry-core==1.2.0", "setuptools_rust==1.5.2"]
+# The upper bounds here are defensive, intended to prevent situations like
+# #13849 and #14079 where we see buildtime or runtime errors caused by build
+# system changes.
+# We are happy to raise these upper bounds upon request,
+# provided we check that it's safe to do so (i.e. that CI passes).
+requires = ["poetry-core>=1.0.0,<=1.3.1", "setuptools_rust>=1.3,<=1.5.2"]
 build-backend = "poetry.core.masonry.api"