summary refs log tree commit diff
path: root/modules/users/Rory.client.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/users/Rory.client.nix')
-rwxr-xr-xmodules/users/Rory.client.nix41
1 files changed, 41 insertions, 0 deletions
diff --git a/modules/users/Rory.client.nix b/modules/users/Rory.client.nix
new file mode 100755
index 0000000..43a9f57
--- /dev/null
+++ b/modules/users/Rory.client.nix
@@ -0,0 +1,41 @@
+{ config, lib, pkgs, home-manager, ... }:
+
+{
+  home-manager.users.Rory = {
+    services.gnome-keyring.enable = lib.mkForce false;
+    
+    # keepassxc, maybe?
+    systemd.user.services.keepassxc = {
+      Unit = {
+        Description = "KeePassXC password manager";
+        #After = [ "graphical-session-pre.target" ];
+        PartOf = [ "default.target" ];
+      };
+
+      Install = { WantedBy = [ "default.target" ]; };
+
+      Service = { 
+        ExecStart = "${pkgs.keepassxc}/bin/keepassxc ~/.secrets.kdbx";
+        Restart = "always";
+      };
+    };
+
+    systemd.user.services.easyeffects = {
+      Unit = {
+        Description = "EasyEffects";
+        #After = [ "graphical-session-pre.target" ];
+        PartOf = [ "default.target" ];
+      };
+
+      Install = { WantedBy = [ "default.target" ]; };
+
+      Service = { 
+        ExecStart = "${pkgs.easyeffects}/bin/easyeffects";
+        Restart = "always";
+      };
+    };
+
+    home.stateVersion = "22.11";
+  };
+}
+