summary refs log tree commit diff
path: root/modules/users/Alice.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/users/Alice.nix')
-rwxr-xr-xmodules/users/Alice.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/modules/users/Alice.nix b/modules/users/Alice.nix
new file mode 100755
index 0000000..e2e343a
--- /dev/null
+++ b/modules/users/Alice.nix
@@ -0,0 +1,17 @@
+{ config, pkgs, ... }:
+
+{
+  imports = [ groups/BugMine-contrib.nix ];
+  users.groups.Alice = {};
+  users.users.Alice = {
+    isSystemUser = true;
+    extraGroups = [ "BugMine-contrib" ];
+    group = "Alice";
+    home = "/group/bugmine-contrib";
+    shell = "${pkgs.git}/bin/git-shell";
+    openssh.authorizedKeys.keys = [
+      "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIPb52m1rnJSffSOJvN6OYkKgK0TmiRKE4SbOKlkT8Tvn"
+    ];
+  };
+}
+