summary refs log tree commit diff
path: root/modules/packages/xdg-desktop-portal-gtk.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/packages/xdg-desktop-portal-gtk.nix')
-rw-r--r--modules/packages/xdg-desktop-portal-gtk.nix53
1 files changed, 28 insertions, 25 deletions
diff --git a/modules/packages/xdg-desktop-portal-gtk.nix b/modules/packages/xdg-desktop-portal-gtk.nix
index fa32730..cfe48d4 100644
--- a/modules/packages/xdg-desktop-portal-gtk.nix
+++ b/modules/packages/xdg-desktop-portal-gtk.nix
@@ -1,17 +1,18 @@
-{ stdenv
-, lib
-, fetchFromGitHub
-, meson
-, ninja
-, pkg-config
-, xdg-desktop-portal
-, gtk3
-, gnome
-, gnome-desktop
-, glib
-, wrapGAppsHook
-, gsettings-desktop-schemas
-, buildPortalsInGnome ? true
+{
+  stdenv,
+  lib,
+  fetchFromGitHub,
+  meson,
+  ninja,
+  pkg-config,
+  xdg-desktop-portal,
+  gtk3,
+  gnome,
+  gnome-desktop,
+  glib,
+  wrapGAppsHook,
+  gsettings-desktop-schemas,
+  buildPortalsInGnome ? true,
 }:
 
 stdenv.mkDerivation (finalAttrs: {
@@ -32,17 +33,19 @@ stdenv.mkDerivation (finalAttrs: {
     wrapGAppsHook
   ];
 
-  buildInputs = [
-    glib
-    gtk3
-    xdg-desktop-portal
-    gsettings-desktop-schemas # settings exposed by settings portal
-    #fontconfig
-  ] ++ lib.optionals buildPortalsInGnome [
-    gsettings-desktop-schemas # settings exposed by settings portal
-    gnome-desktop
-    gnome.gnome-settings-daemon # schemas needed for settings api (mostly useless now that fonts were moved to g-d-s, just mouse and xsettings)
-  ];
+  buildInputs =
+    [
+      glib
+      gtk3
+      xdg-desktop-portal
+      gsettings-desktop-schemas # settings exposed by settings portal
+      #fontconfig
+    ]
+    ++ lib.optionals buildPortalsInGnome [
+      gsettings-desktop-schemas # settings exposed by settings portal
+      gnome-desktop
+      gnome.gnome-settings-daemon # schemas needed for settings api (mostly useless now that fonts were moved to g-d-s, just mouse and xsettings)
+    ];
 
   mesonFlags = lib.optionals (!buildPortalsInGnome) [
     "-Dwallpaper=disabled"