summary refs log tree commit diff
path: root/modules/packages/vim.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/packages/vim.nix')
-rw-r--r--modules/packages/vim.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/modules/packages/vim.nix b/modules/packages/vim.nix
new file mode 100644
index 0000000..3524e2c
--- /dev/null
+++ b/modules/packages/vim.nix
@@ -0,0 +1,22 @@
+{ pkgs, ... }:
+{
+  environment.variables = { EDITOR = "vim"; };
+
+  environment.systemPackages = with pkgs; [
+    (neovim.override {
+      vimAlias = true;
+      configure = {
+        packages.myPlugins = with pkgs.vimPlugins; {
+          start = [ vim-lastplace vim-nix vim-airline ]; 
+          opt = [];
+        };
+        customRC = ''
+          " your custom vimrc
+          set nocompatible
+          set backspace=indent,eol,start
+          " ...
+        '';
+      };
+    }
+  )];
+}