summary refs log tree commit diff
path: root/modules/packages/mtxclient-git.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/packages/mtxclient-git.nix')
-rw-r--r--modules/packages/mtxclient-git.nix34
1 files changed, 19 insertions, 15 deletions
diff --git a/modules/packages/mtxclient-git.nix b/modules/packages/mtxclient-git.nix
index d2a9d6a..2392312 100644
--- a/modules/packages/mtxclient-git.nix
+++ b/modules/packages/mtxclient-git.nix
@@ -1,19 +1,21 @@
 # This file was copied from NUR: https://github.com/nix-community/nur-combined/blob/master/repos/deeunderscore/pkgs/mtxclient/default.nix
 # This file is a modified version of nixpkgs/pkgs/development/libraries/mtxclient/default.nix (copied at 5c4b9be)
 
-{ lib, stdenv
-, fetchFromGitHub
-, cmake
-, pkg-config
-, openssl
-, olm
-, spdlog
-, nlohmann_json
-, libevent
-, curl
-, coeurl
-, re2
-, mtxclientSrc
+{
+  lib,
+  stdenv,
+  fetchFromGitHub,
+  cmake,
+  pkg-config,
+  openssl,
+  olm,
+  spdlog,
+  nlohmann_json,
+  libevent,
+  curl,
+  coeurl,
+  re2,
+  mtxclientSrc,
 }:
 stdenv.mkDerivation {
   pname = "mtxclient";
@@ -32,7 +34,6 @@ stdenv.mkDerivation {
     sed -i '1a add_compile_definitions(SPDLOG_FMT_EXTERNAL)' CMakeLists.txt
   '';
 
-
   nativeBuildInputs = [
     cmake
     pkg-config
@@ -52,7 +53,10 @@ stdenv.mkDerivation {
     description = "Client API library for Matrix, built on top of Boost.Asio";
     homepage = "https://github.com/Nheko-Reborn/mtxclient";
     license = licenses.mit;
-    maintainers = with maintainers; [ fpletz pstn ];
+    maintainers = with maintainers; [
+      fpletz
+      pstn
+    ];
     platforms = platforms.all;
     # Should be fixable if a higher clang version is used, see:
     # https://github.com/NixOS/nixpkgs/pull/85922#issuecomment-619287177