summary refs log tree commit diff
path: root/modules/monitoring/module.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/monitoring/module.nix')
-rw-r--r--modules/monitoring/module.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/modules/monitoring/module.nix b/modules/monitoring/module.nix
index 60e396d..1197643 100644
--- a/modules/monitoring/module.nix
+++ b/modules/monitoring/module.nix
@@ -32,9 +32,9 @@ in
       type = lib.types.listOf lib.types.int;
       default = [
         1
-        2
-        5
-        15
+        #2 # kinda pointless?
+        #5 # doesnt help with reliability
+        #15 # might aswell just use a 15s interval on grafana
       ];
       description = "Scrape intervals for Prometheus";
     };
@@ -45,6 +45,9 @@ in
       prometheus = lib.mkIf (cfg.localPrometheus) {
         enable = true;
         listenAddress = "127.0.0.1";
+        extraFlags = [
+          "--storage.tsdb.wal-compression=true"
+        ];
       };
       grafana = lib.mkIf (cfg.localGrafana) {
         enable = true;