summary refs log tree commit diff
path: root/modules/environments/home.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/environments/home.nix')
-rwxr-xr-xmodules/environments/home.nix17
1 files changed, 11 insertions, 6 deletions
diff --git a/modules/environments/home.nix b/modules/environments/home.nix
index 9bfb80e..0658abb 100755
--- a/modules/environments/home.nix
+++ b/modules/environments/home.nix
@@ -3,20 +3,24 @@
 {
   nix = {
     distributedBuilds = true;
-
-    buildMachines = [
-      #"self" = {
-      #  
-      #};
+# 
+    buildMachines = builtins.filter (machine: !builtins.any (ip: ip == machine.hostName) (builtins.map (iface: iface.ipv4.addresses) (builtins.attrValues config.networking.interfaces))) [
       {
         systems = [ "x86_64-linux" "i686-linux" ];
         hostName = "192.168.0.3";
         sshUser = "Rory";
         sshKey = "/home/Rory/.ssh/id_ed25519";
         maxJobs = 6;
-        #cores = 2;
         speedFactor = 43200;
       }
+      {
+        systems = [ "x86_64-linux" "i686-linux" ];
+        hostName = "192.168.0.59";
+        sshUser = "Rory";
+        sshKey = "/home/Rory/.ssh/id_ed25519";
+        maxJobs = 2;
+        speedFactor = 16000;
+      }
     ];
     
     #ssh://Rory@192.168.0.3 x86_64-linux,i686-linux /home/Rory/.ssh/id_ed25519 12 1 - - -
@@ -35,6 +39,7 @@
         "cache.garnix.io:CTFPyKSLcx5RMJKfLo5EEPUObbA78b0YQ2DTCJXqr9g="
         "numtide.cachix.org-1:2ps1kLBUWjxIneOy1Ik6cQjb41X0iXVXeHigGmycPPE="
       ];
+      trusted-users = [ "root" "@wheel" "Rory" ];
     };
   };