summary refs log tree commit diff
path: root/modules/base-server.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/base-server.nix')
-rwxr-xr-xmodules/base-server.nix32
1 files changed, 2 insertions, 30 deletions
diff --git a/modules/base-server.nix b/modules/base-server.nix
index f5d33af..9e248e4 100755
--- a/modules/base-server.nix
+++ b/modules/base-server.nix
@@ -17,30 +17,11 @@
 
   environment.variables.BROWSER = "echo";
 
-  nix.settings.trusted-users = [
-    "root"
-    "@wheel"
-  ];
-
   time.timeZone = lib.mkDefault "UTC";
   systemd = {
-    # Given that our systems are headless, emergency mode is useless.
-    # We prefer the system to attempt to continue booting so
-    # that we can hopefully still access it remotely.
     enableEmergencyMode = false;
-
-    # For more detail, see:
-    #   https://0pointer.de/blog/projects/watchdog.html
     watchdog = {
-      # systemd will send a signal to the hardware watchdog at half
-      # the interval defined here, so every 10s.
-      # If the hardware watchdog does not get a signal for 20s,
-      # it will forcefully reboot the system.
       runtimeTime = "20s";
-      # Forcefully reboot if the final stage of the reboot
-      # hangs without progress for more than 30s.
-      # For more info, see:
-      #   https://utcc.utoronto.ca/~cks/space/blog/linux/SystemdShutdownWatchdog
       rebootTime = "30s";
     };
 
@@ -50,16 +31,8 @@
     '';
   };
 
-  systemd.services.NetworkManager-wait-online.enable = false;
-  systemd.network.wait-online.enable = false;
-  # systemd.services.systemd-networkd.stopIfChanged = false;
-  # systemd.services.systemd-resolved.stopIfChanged = false;
-  nix.settings.max-free = lib.mkDefault (1000 * 1000 * 1000);
-  nix.settings.min-free = lib.mkDefault (128 * 1000 * 1000);
-
-  nix.daemonCPUSchedPolicy = lib.mkDefault "batch";
-  nix.daemonIOSchedClass = lib.mkDefault "idle";
-  nix.daemonIOSchedPriority = lib.mkDefault 7;
+  #systemd.services.NetworkManager-wait-online.enable = false;
+  #systemd.network.wait-online.enable = false;
 
   # My servers always use /dev/vda as boot disk...
   boot = {
@@ -107,7 +80,6 @@
   hardware.enableAllFirmware = false;
   hardware.enableRedistributableFirmware = false;
 
-  i18n.defaultLocale = "en_US.UTF-8";
   services = {
     prometheus = {
       exporters = {