summary refs log tree commit diff
path: root/modules/base-client.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/base-client.nix')
-rwxr-xr-xmodules/base-client.nix27
1 files changed, 16 insertions, 11 deletions
diff --git a/modules/base-client.nix b/modules/base-client.nix
index c88db02..936e426 100755
--- a/modules/base-client.nix
+++ b/modules/base-client.nix
@@ -1,11 +1,15 @@
-{ config, pkgs, lib, ... }:
+{
+  config,
+  pkgs,
+  lib,
+  ...
+}:
 
 {
-  imports =
-    [
-      ./base.nix
-      ./users/Rory.client.nix
-    ];
+  imports = [
+    ./base.nix
+    ./users/Rory.client.nix
+  ];
 
   networking = {
     hostName = lib.mkDefault "Rory-nix-base";
@@ -22,7 +26,7 @@
     sleep.extraConfig = ''
       AllowSuspend=no
       AllowHibernation=no
-      '';
+    '';
   };
 
   environment.systemPackages = with pkgs; [
@@ -51,7 +55,10 @@
   '';
   nix = {
     settings = {
-      experimental-features = [ "nix-command" "flakes" ];
+      experimental-features = [
+        "nix-command"
+        "flakes"
+      ];
       auto-optimise-store = true;
     };
   };
@@ -67,8 +74,6 @@
   boot.initrd.systemd.network.wait-online.enable = false;
 
   # disable all serial ports/consoles
-  systemd.suppressedSystemUnits = [ 
-    "serial-getty@.service"
-  ];
+  systemd.suppressedSystemUnits = [ "serial-getty@.service" ];
 
 }