summary refs log tree commit diff
path: root/host/Rory-wsl/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-wsl/configuration.nix')
-rw-r--r--host/Rory-wsl/configuration.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/host/Rory-wsl/configuration.nix b/host/Rory-wsl/configuration.nix
index 35eaff5..313eeb4 100644
--- a/host/Rory-wsl/configuration.nix
+++ b/host/Rory-wsl/configuration.nix
@@ -1,6 +1,9 @@
 { lib, pkgs, config, modulesPath, ... }:
 
 {
+  imports = [
+    ../../modules/base-client.nix
+  ];
   wsl = {
     enable = true;
     automountPath = "/mnt";
@@ -14,10 +17,7 @@
     # docker-desktop.enable = true;
 
   };
-
-  nix.extraOptions = ''
-    experimental-features = nix-command flakes
-  '';
+  networking.hostName = "Rory-wsl";
 
   environment.systemPackages = with pkgs; [
     wget
@@ -43,4 +43,5 @@
   ];
 
   system.stateVersion = "23.05";
+  home-manager.users.Rory.home.stateVersion = "23.05";
 }