summary refs log tree commit diff
path: root/host/Rory-synapse/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-synapse/configuration.nix')
-rwxr-xr-xhost/Rory-synapse/configuration.nix21
1 files changed, 3 insertions, 18 deletions
diff --git a/host/Rory-synapse/configuration.nix b/host/Rory-synapse/configuration.nix
index a105757..0542abd 100755
--- a/host/Rory-synapse/configuration.nix
+++ b/host/Rory-synapse/configuration.nix
@@ -144,12 +144,12 @@
     
   };
 
-  services.mjolnir = {
+  services.draupnir = {
     enable = true;
     pantalaimon = {
       enable = true;
-      username = "mjolnir";
-      passwordFile = "/run/secrets/mjolnir-password";
+      username = "draupnir";
+      passwordFile = "/run/secrets/draupnir-password";
       options = {
         homeserver = "http://localhost:8008";
         ssl = false;
@@ -161,20 +161,5 @@
   };
 
   system.stateVersion = "22.11"; # DO NOT EDIT!
-
-  nixpkgs.overlays = [
-    (self: super: {
-        mjolnir = super.mjolnir.overrideAttrs (old: {
-          #pname = "Draupnir";
-          #version = "1.81.0";
-          src = self.fetchFromGitHub {
-            owner = "Gnuxie";
-            repo = "Draupnir";
-            rev = "v1.81.0";
-            hash = "sha256-Z2nmTknYfXmzBzr2TY8ylb0KulT3k2D7Evymu+vykuQ=";
-          };
-        });
-    })
-  ];
 }