summary refs log tree commit diff
path: root/host/Rory-postgres/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-postgres/configuration.nix')
-rw-r--r--host/Rory-postgres/configuration.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/host/Rory-postgres/configuration.nix b/host/Rory-postgres/configuration.nix
new file mode 100644
index 0000000..d224e78
--- /dev/null
+++ b/host/Rory-postgres/configuration.nix
@@ -0,0 +1,22 @@
+{ config, pkgs, lib, ... }:
+
+{
+  imports =
+    [
+      ../../modules/base-server.nix
+    ];
+
+  networking = {
+    hostName = "Rory-postgres";
+    interfaces.ens18.ipv4.addresses = [ { 
+      address = "192.168.1.3";
+      prefixLength = 24;
+    } ];
+  };
+
+  environment.systemPackages = with pkgs; [
+  ];
+
+  system.stateVersion = "22.11"; # DO NOT EDIT!
+}
+