summary refs log tree commit diff
path: root/host/Rory-nginx/software.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-nginx/software.nix')
-rwxr-xr-xhost/Rory-nginx/software.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/host/Rory-nginx/software.nix b/host/Rory-nginx/software.nix
index 8aa07bf..6423c08 100755
--- a/host/Rory-nginx/software.nix
+++ b/host/Rory-nginx/software.nix
@@ -13,6 +13,10 @@
       package = pkgs.nginxQuic;
       recommendedProxySettings = true;
       recommendedTlsSettings = true;
+      recommendedZstdSettings = true;
+      recommendedGzipSettings = true;
+      recommendedBrotliSettings = true;
+      recommendedOptimisation = true;
       defaultMimeTypes = ../../modules/packages/nginx/mime.types;
       appendConfig = ''
         worker_processes 16;
@@ -22,9 +26,12 @@
         worker_connections 512;
         '';
       appendHttpConfig = ''
-        sendfile on;
+        #sendfile on;
       '';
       upstreams = import ./matrix/upstreams.nix;
+      additionalModules = with pkgs.nginxModules; [
+        moreheaders
+      ];
       virtualHosts = {
         "siliconheaven.thearcanebrony.net" = import ./hosts/thearcanebrony.net/siliconheaven.nix;
         "lfs.thearcanebrony.net" = import ./hosts/thearcanebrony.net/lfs.nix;