summary refs log tree commit diff
path: root/host/Rory-nginx/services/matrix/synapse/workers/pusher.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-nginx/services/matrix/synapse/workers/pusher.nix')
-rw-r--r--host/Rory-nginx/services/matrix/synapse/workers/pusher.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/host/Rory-nginx/services/matrix/synapse/workers/pusher.nix b/host/Rory-nginx/services/matrix/synapse/workers/pusher.nix
index 3391171..ad0d5d6 100644
--- a/host/Rory-nginx/services/matrix/synapse/workers/pusher.nix
+++ b/host/Rory-nginx/services/matrix/synapse/workers/pusher.nix
@@ -1,6 +1,9 @@
 { config, lib, ... }:
 let
   cfg = config.services.matrix-synapse;
+  dbGroup = "small";
+  hasClientResource = false;
+  hasFederationResource = false;
   pushers = lib.range 0 (cfg.pushers - 1);
   workerName = "pusher";
   workerRoutes = [ ];
@@ -40,8 +43,8 @@ in
             ];
             database = (
               import ../db.nix {
+                inherit dbGroup;
                 workerName = "${workerName}-${toString index}";
-                dbGroup = "small";
               }
             );
           };