summary refs log tree commit diff
path: root/host/Rory-nginx/services/matrix/synapse/workers/pusher.nix
diff options
context:
space:
mode:
authorRory& <root@rory.gay>2024-08-16 12:16:21 +0200
committerRory& <root@rory.gay>2024-08-16 12:16:21 +0200
commit9778db57511950cda9d5c0f8955597d6b2282302 (patch)
treee946d27d44b425986240dd731afea7944894df1a /host/Rory-nginx/services/matrix/synapse/workers/pusher.nix
parentNginx log request times (diff)
downloadRory-Open-Architecture-9778db57511950cda9d5c0f8955597d6b2282302.tar.xz
Some synapse workers cleanup
Diffstat (limited to 'host/Rory-nginx/services/matrix/synapse/workers/pusher.nix')
-rw-r--r--host/Rory-nginx/services/matrix/synapse/workers/pusher.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/host/Rory-nginx/services/matrix/synapse/workers/pusher.nix b/host/Rory-nginx/services/matrix/synapse/workers/pusher.nix
index 3391171..ad0d5d6 100644
--- a/host/Rory-nginx/services/matrix/synapse/workers/pusher.nix
+++ b/host/Rory-nginx/services/matrix/synapse/workers/pusher.nix
@@ -1,6 +1,9 @@
 { config, lib, ... }:
 let
   cfg = config.services.matrix-synapse;
+  dbGroup = "small";
+  hasClientResource = false;
+  hasFederationResource = false;
   pushers = lib.range 0 (cfg.pushers - 1);
   workerName = "pusher";
   workerRoutes = [ ];
@@ -40,8 +43,8 @@ in
             ];
             database = (
               import ../db.nix {
+                inherit dbGroup;
                 workerName = "${workerName}-${toString index}";
-                dbGroup = "small";
               }
             );
           };