summary refs log tree commit diff
path: root/host/Rory-nginx/services/matrix/synapse/workers/module.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-nginx/services/matrix/synapse/workers/module.nix')
-rw-r--r--host/Rory-nginx/services/matrix/synapse/workers/module.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/host/Rory-nginx/services/matrix/synapse/workers/module.nix b/host/Rory-nginx/services/matrix/synapse/workers/module.nix
index 84b8a87..080f524 100644
--- a/host/Rory-nginx/services/matrix/synapse/workers/module.nix
+++ b/host/Rory-nginx/services/matrix/synapse/workers/module.nix
@@ -19,8 +19,11 @@ in
     ./appservice.nix
     ./background.nix
     ./federation-sender.nix
+    ./media-repo.nix
     ./pusher.nix
+    ./sync.nix
     ./user-dir.nix
+
     ./stream-writers/event-stream-writer.nix
   ];
   options.services.matrix-synapse =
@@ -60,6 +63,16 @@ in
         default = 0;
         description = "Number of pushers";
       };
+      mediaRepoWorkers = lib.mkOption {
+        type = lib.types.int;
+        default = 0;
+        description = "Number of media repo workers";
+      };
+      syncWorkers = lib.mkOption {
+        type = lib.types.int;
+        default = 0;
+        description = "Number of sync workers";
+      };
 
       nginxVirtualHostName = lib.mkOption {
         type = lib.types.str;